SRT support build on Debian Buster. Nothing available yet. Cerbero fails to configure for source install.

Daniel Rossi electroteque at
Mon Jul 15 09:09:19 UTC 2019

This is the exact problem on windows.

I've gone around in circles with getting it installed on Debian, I need 
to get a working Debian package anyway for Raspberry PI targets. The 
gst-build project was a failure. I couldnt get it properly installed and 
running gst-launch, it complained about missing a gst-doc project after 
an hour downloading and compiling.

I've tried cerbero twice. It failed intially on a PI Desktop Debian 
image because of wierd arch issues with 32 bit library locations. It 
successfully built packages on Debian 10, but it did not go as far as 
install the packages. It seems to not have made a package for 
"plugins-bad" which is needed for SRT support and there is zero 
documentation how to do that.

I tried to install gstreamer as a binary package and recompile 
"plugins-bad" from sources but it complained about not finding a 
gstreamer version that was already there so I scrapped trying there. 
According to these docs. This documented process worked on Ubuntu Server 

I've hit deadends and roadblocks along the way for something that might 
have taken a few minutes to install.  I've spent 3 days trying to get a 
working linux binary because SRT is missing from the Debian/Ubuntu 
packages. Still nothing yet.

This is the Windows output.

gst-launch-1.0 -v srtserversrc uri="srt://" ! decodebin ! 
Setting pipeline to PAUSED ...
Pipeline is live and does not need PREROLL ...
Setting pipeline to PLAYING ...
New clock: GstSystemClock
18:55:57.646831!!FATAL!!: SRT.c: CChannel reported ERROR DURING 

Acting as a pull client test has been working with the Windows version. 
I was able to test gst-launch on the Ubuntu server where wowza is. So 
locally that was working but I need to do remote tests to  receiver 
client behind a NAT. Wowza SRT transmission acts as a push to the client 
acting as a UDP server. I've not managed to test this and confirm NAT 
configuring on my EdgeRouter is actually working.

------ Original Message ------
From: "Nicolas Dufresne" <nicolas at>
To: "Daniel Rossi" <electroteque at>; "Discussion of the 
development of and with GStreamer" 
<gstreamer-devel at>
Sent: 7/13/2019 10:42:31 PM
Subject: Re: SRT support build on Debian Buster. Nothing available yet. 
Cerbero fails to configure for source install.

>Le samedi 13 juillet 2019 à 11:46 +0000, Daniel Rossi a écrit :
>>  Hi , of all the packages I've built in my time, this one has to be
>>  the most broken one I have seen so far and the most complicated to
>>  get installed and working properly. It has been a failure in Debian,
>>  Ubuntu, Amazon Linux AMI etc.
>>  Ive been trying for days to get a gstreamer package with SRT support
>>  working. It was completely missing from the bad plugins package.
>>  According to this post, I was able to rebuild just the bad plugins
>>  repository with libsrt, in Ubutu server. But in Debian Buster , it
>>  complained about missing a plugins base package verson which was
>>  installed
>>  This led me to attempting to rebuild the whole thing from sources. I
>>  need this tool for testing SRT streaming functionality, and its taken
>>  a few days to get to this point. The Windows binary crashes when
>>  trying to turn the receiver into SRT server mode (For testing Wowza
>>  SRT Push streaming)
>Could it be that one ?
>    1. Note that I notice that SRT elements only works when configured
>       through URI, configuring through the properties seems broken. I must
>       admit I thought this crash was introduced by the re-factoring (the
>       one that merge srtserver/client pairs to allow fully URI based
>       handling.
>>  My target environment will be a receiver on Raspberry PI. But I am
>>  trying to get it built within the PI Desktop VMware for now.
>>  On attempting to setup cerbero according to the docs. In Debian
>>  Buster, configure fails. Any help would be good, so i can move on
>>  confirming UDP NAT issues with SRT.
>SRT is NAT friendly in the sense it uses a single port, but you still
>need to port forward, as it does not do NAT traversal like WebRTC as an
>>  checking for gcc... gcc
>>  checking whether the C compiler works... no
>>  configure: error: in `/home/pi/Downloads/cerbero/build/sources/build-
>>  tools/m4-1.4.18':
>>  configure: error: C compiler cannot create executables
>>  See `config.log' for more details
>More details are inside config.log as stated by this message.
>>  ***** Error running 'bootstrap' command:
>>  Recipe 'm4' failed at the build step 'configure'
>>  Fatal Error: Running ['sh', '-c', './configure --prefix
>>  /home/pi/Downloads/cerbero/build/build-tools --libdir
>>  /home/pi/Downloads/cerbero/build/build-tools/lib --with-pic  --
>>  disable-maintainer-mode  --disable-silent-rules  --disable-gtk-doc
>>  --disable-introspection    --disable-gcc-warnings  --with-pic  --
>>  disable-maintainer-mode  --disable-silent-rules  --disable-gtk-doc
>>  --disable-introspection    --disable-gcc-warnings '], returncode 77
>>  _______________________________________________
>>  gstreamer-devel mailing list
>>  gstreamer-devel at
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the gstreamer-devel mailing list