Reading streaming video frame by frame

omer.tal jacklawi at
Tue Nov 24 17:42:30 UTC 2020

Hey... Sorry for the late response.

So I downloaded the file modified_as_suggested.c..

Firstly, I tried to ping the IP address which is in the pipeline. I got no
response, so obviously I could not use your pipeline.
So I took a pipeline which I use for my own development (and kept your
appsink element as is):

*rtspsrc location=rtsp:// ! rtph264depay name=depay !
h264parse ! avdec_h264 ! videoconvert ! videoscale ! appsink name=video-sink
caps=\"video/x-raw,format=RGB,pixel-aspect-ratio=1/1\"", NULL*

With this pipeline everything worked fine. 

Please try the following pipeline and see if you get anything on standard
*videotestsrc ! appsink name=video-sink

I've tested this (just to be sure) on my machine and it worked just fine. If
it doesn't work for you it must be environment issues (though I highly doubt
if that's the case).

Sent from:

More information about the gstreamer-devel mailing list