rtp stream from jetson nano to surface pro running arch

Edward Anon blakat360 at gmail.com
Fri Jun 25 20:50:12 UTC 2021

I've tried the following setup:
./test-launch "ximagesrc use-damage=0 ! nvvidconv ! nvv4l2h265enc !
h265parse ! video/x-h265, stream-format=byte-stream ! rtph265pay name=pay0
pt=96 "
gst-launch-1.0 -v rtspsrc location=rtsp://<Jetson_IP>:8554/test !
application/x-rtp, media=video, encoding-name=H265 ! rtph265depay !
avdec_h265 ! xvimagesink

As well as constructing similar pipelines directly udpsrc and udpsink. I
can see that in both cases I get a connection, a redistribute latency
signal is broadcast and the pipeline throws an internal data stream error
at udpsrc. It then tells me that the pipeline is not properly negotiated.

I understand that this is an issue with capabilities and will most likely
be resolved by setting the correct caps on the udpsrc or sending the
correct stream format over the network. What baffles me is that these
examples which were accepted solutions on forums are failing in my specific
use case.

Examples from here
and here
also give me the same error.

What am I doing wrong?
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.freedesktop.org/archives/gstreamer-devel/attachments/20210625/d024aa4a/attachment.htm>

More information about the gstreamer-devel mailing list