, take 2

Danny Kukawka danny.kukawka at
Thu Aug 3 09:58:40 PDT 2006

On Thursday 03 August 2006 18:21, Arnaud Quette wrote:
> 2006/8/3, Danny Kukawka <danny.kukawka at>:
> > Btw. I think currently about a utils-pm.c/h or something like that, to
> > move _all_ the battery related stuff (functions and objects) to an own
> > file, because this stuff is only used by acpi/pmu atm (+ maybe apm in the
> > future) and not needed in any other part of HAL than for battery
> > handling.
> you should take a look at my mail (Common Power Management...) for the
> UPS side, and future power extensions.

IMO this has nothing to do with what I proposed above. I only think about move 
all battery/pm related helperfunctions from utils.c/h to a own file. This is 
more a code design issue than anything other.


More information about the hal mailing list