Add a simple version of the toshiba acpi addon

David Zeuthen david at
Fri Mar 3 07:54:28 PST 2006

On Wed, 2006-03-01 at 20:24 +0000, Richard Hughes wrote:
> Will do. The addon look okay to commit?


> -hald-addon-acpi
> -hald-addon-hid-ups
> -hald-addon-pmu
> -hald-addon-storage
> -hald-addon-usb-csr
> -hald-addon-keyboard
> +hald-addon-*

I'm not sure this works on a clean tree and if it does I'm not sure I
like it. I like to be explicit about what programs we build.

> +                       result = "brightness_down";
> +               else if (value == 0x141) /* FnF7 */
> +                       result = "brightness_up";
> +               else if (value == 0x142) /* FnF8 */
> +                       result = "wifi_power";

Should use - instead of _ for the button names... btw.. did you have a
patch for doing s/_/-/ everywhere as well as adding it to the spec? I
didn't see it. That patch should go in at the same time as this patch.

Apart from that it looks good to me. Thanks.


More information about the hal mailing list