Initial cleanup patch : acpi.c

Danny Kukawka danny.kukawka at
Mon Mar 13 06:03:18 PST 2006

On Monday 13 March 2006 14:41, Richard Hughes wrote:
> > Sorry, but is this really needed ... I have here also machines with XGA
> > and I only need to change my font if the lines are to long ... or is this
> > not possible?
> It's an 800x600 screen. I can't see much below 8pt and it not fun to
> program with fonts that small.

... okay, I check this on my old _VGA_ b/w monitor ... 

> > Btw.:
> > - add variable calculate_per_time is not needed if you use this variable
> > only one time. You should let this as it was.
> For readability I added one boolean. The compiler will probably inline
> it, so net object code change is (or should be) no different.

_probably_: but then you also can let it as it was ... we have enough 
performacance problems with hal we not need to add more not really needed 
variables. If we can optimice the code directly let do it and avoid not 
needed codelines.

> > - I don't understand the comment 2 (* Adds the omitted
> > battery.reporting.last_full ... ) in relation to the code and the
> > changes.
> battery.reporting.last_full was only being updated in
> battery_poll_infrequently, and not in battery coldplug.

But direct after call battery_refresh_add() always the function 
battery_refresh_poll() is called which already add the key ... this operation 
is not needed twice time directly in succession.


More information about the hal mailing list