[igt-dev] [PATCH i-g-t 8/8] i915/gem_exec_basic: Use dynamic subtests
Tvrtko Ursulin
tvrtko.ursulin at linux.intel.com
Fri Nov 8 16:31:24 UTC 2019
On 24/10/2019 12:05, Petri Latvala wrote:
> Instead of generating a subtest for each engine in a static list,
> convert to dynamic subtests, with one dynamic subtest per actually
> present physical engine.
>
> Signed-off-by: Petri Latvala <petri.latvala at intel.com>
> ---
> tests/i915/gem_exec_basic.c | 26 +++++++++++++++++++-------
> 1 file changed, 19 insertions(+), 7 deletions(-)
>
> diff --git a/tests/i915/gem_exec_basic.c b/tests/i915/gem_exec_basic.c
> index 1287860b..b2d6ddc2 100644
> --- a/tests/i915/gem_exec_basic.c
> +++ b/tests/i915/gem_exec_basic.c
> @@ -159,13 +159,25 @@ igt_main
> igt_subtest("gtt-all")
> gtt_all(fd);
>
> - __for_each_physical_engine(fd, e) {
> - igt_subtest_f("basic-%s", e->name)
> - noop(fd, e->flags);
> - igt_subtest_f("readonly-%s", e->name)
> - readonly(fd, e->flags);
> - igt_subtest_f("gtt-%s", e->name)
> - gtt(fd, e->flags);
> + igt_subtest_with_dynamic_subsubtests("basic") {
Bikeshed on the name maybe, since "subsub" reads a bit funny.
igt_dynamic_subtest_group ?
Regards,
Tvrtko
> + __for_each_physical_engine(fd, e) {
> + igt_dynamic_subsubtest_f("%s", e->name)
> + noop(fd, e->flags);
> + }
> + }
> +
> + igt_subtest_with_dynamic_subsubtests("readonly") {
> + __for_each_physical_engine(fd, e) {
> + igt_dynamic_subsubtest_f("%s", e->name)
> + readonly(fd, e->flags);
> + }
> + }
> +
> + igt_subtest_with_dynamic_subsubtests("gtt") {
> + __for_each_physical_engine(fd, e) {
> + igt_dynamic_subsubtest_f("%s", e->name)
> + gtt(fd, e->flags);
> + }
> }
>
> igt_fixture {
>
More information about the igt-dev
mailing list