[igt-dev] [PATCH i-g-t 8/8] i915/gem_exec_basic: Use dynamic subtests

Tvrtko Ursulin tvrtko.ursulin at linux.intel.com
Fri Nov 8 16:33:24 UTC 2019


On 08/11/2019 16:31, Tvrtko Ursulin wrote:
> 
> On 24/10/2019 12:05, Petri Latvala wrote:
>> Instead of generating a subtest for each engine in a static list,
>> convert to dynamic subtests, with one dynamic subtest per actually
>> present physical engine.
>>
>> Signed-off-by: Petri Latvala <petri.latvala at intel.com>
>> ---
>>   tests/i915/gem_exec_basic.c | 26 +++++++++++++++++++-------
>>   1 file changed, 19 insertions(+), 7 deletions(-)
>>
>> diff --git a/tests/i915/gem_exec_basic.c b/tests/i915/gem_exec_basic.c
>> index 1287860b..b2d6ddc2 100644
>> --- a/tests/i915/gem_exec_basic.c
>> +++ b/tests/i915/gem_exec_basic.c
>> @@ -159,13 +159,25 @@ igt_main
>>       igt_subtest("gtt-all")
>>           gtt_all(fd);
>> -    __for_each_physical_engine(fd, e) {
>> -        igt_subtest_f("basic-%s", e->name)
>> -            noop(fd, e->flags);
>> -        igt_subtest_f("readonly-%s", e->name)
>> -            readonly(fd, e->flags);
>> -        igt_subtest_f("gtt-%s", e->name)
>> -            gtt(fd, e->flags);
>> +    igt_subtest_with_dynamic_subsubtests("basic") {
> 
> Bikeshed on the name maybe, since "subsub" reads a bit funny.
> 
> igt_dynamic_subtest_group ?

Assuming at least it can both nest under igt_subtest_group and not nest 
ie. be at top-level? Do we need a nested version even?

Regards,

Tvrtko

> Regards,
> 
> Tvrtko
> 
>> +        __for_each_physical_engine(fd, e) {
>> +            igt_dynamic_subsubtest_f("%s", e->name)
>> +                noop(fd, e->flags);
>> +        }
>> +    }
>> +
>> +    igt_subtest_with_dynamic_subsubtests("readonly") {
>> +        __for_each_physical_engine(fd, e) {
>> +            igt_dynamic_subsubtest_f("%s", e->name)
>> +                readonly(fd, e->flags);
>> +        }
>> +    }
>> +
>> +    igt_subtest_with_dynamic_subsubtests("gtt") {
>> +        __for_each_physical_engine(fd, e) {
>> +            igt_dynamic_subsubtest_f("%s", e->name)
>> +                gtt(fd, e->flags);
>> +        }
>>       }
>>       igt_fixture {
>>
> _______________________________________________
> igt-dev mailing list
> igt-dev at lists.freedesktop.org
> https://lists.freedesktop.org/mailman/listinfo/igt-dev


More information about the igt-dev mailing list