[v1] tests/intel: Remove TEST field from test documentation
Kamil Konieczny
kamil.konieczny at linux.intel.com
Fri Dec 20 15:24:03 UTC 2024
Hi Pravalika,
On 2024-12-20 at 15:09:14 +0530, Pravalika Gurram wrote:
I would suggest changeing subject into having test name in prefix,
also shorten it into:
[i-g-t v1] tests/intel/xe_vm: Fixed documentation
> Each test should contain only one TEST field.
>
> Add the Functionality field in the TEST section
> to fix the warnings during the addition of subtests.
>
Here you could add Fixes: tag like
Fixes: 4d630db8b8cf ("tests/intel/xe_vm: Check negative cases for vm_create/destroy ioctl")
but imho if it is very recent it could be skipped. We also
do not have stable branches so it is not required.
Add also here:
Cc: Katarzyna Piecielska <katarzyna.piecielska at intel.com>
> Signed-off-by: Pravalika Gurram <pravalika.gurram at intel.com>
> ---
> tests/intel/xe_vm.c | 10 +---------
> 1 file changed, 1 insertion(+), 9 deletions(-)
>
> diff --git a/tests/intel/xe_vm.c b/tests/intel/xe_vm.c
> index b10269191..b5519c9fc 100644
> --- a/tests/intel/xe_vm.c
> +++ b/tests/intel/xe_vm.c
> @@ -8,6 +8,7 @@
> * Category: Core
> * Mega feature: General Core features
> * Sub-category: VMA
> + * Functionality: ioctl
imho this should be added at each new subtests you introduced
in your previous change. Maybe more proper name would be:
* Functionality: input_validation
or
* Functionality: ioctl_input_validation
What do you think about this, Kasia?
Regards,
Kamil
> */
>
> #include "igt.h"
> @@ -2247,15 +2248,6 @@ static void bind_flag_invalid(int fd)
> xe_vm_destroy(fd, vm);
> }
>
> -/**
> - * TEST: Negative test for vm create/destroy ioctl
> - * Category: Core
> - * Mega feature: General Core features
> - * Sub-category: Synchronization
> - * Functionality: vm create
> - * Test category: negative test
> - */
> -
> /**
> * SUBTEST: invalid-flag-%s
> * Description: function %arg[1] used in vm create IOCTL to make it fail
More information about the igt-dev
mailing list