[immodule-qt] BC patch for Qt 3.3.2
Lars Knoll
lars at trolltech.com
Fri Jul 23 12:34:33 EEST 2004
Hi,
I've looked through the BC patch for Qt 3.3.2. I didn't try to use it up to
now, so I can't really comment on that. But I have one or two comments
concerning the code in qapplication_x11.cpp:
-static char *ximServer = 0; // XIM Server will connect to
+char *ximServer = 0; // XIM Server will connect to
This would add an exported ximServer symbol to the Qt lib, that might lead to
clashes if applications use the same symbol name. In general all variables or
methods that are not static have to be prefixed with qt_. So it would be best
to rename it to qt_ximServer.
+XIMStyle xim_preferred_style = 0;
static XIMStyle xim_default_style = XIMPreeditCallbacks | XIMStatusNothing;
-static XIMStyle xim_preferred_style = 0;
-static int composingKeycode=0;
-static QTextCodec * input_mapper = 0;
+int composingKeycode=0;
+QTextCodec * input_mapper = 0;
Same as above. Please rename to qt_xim_preferred_style, etc.
+ defaultIM = settings.readEntry( "/qt/DefaultInputMethod", QObject::trUtf8
( "XIM" ) );
I don't think you should translate the default for the config entry, so the
line should rather be:
+ defaultIM = settings.readEntry( "/qt/DefaultInputMethod", "XIM" );
Best regards,
Lars
More information about the immodule-qt
mailing list