[Bug 108646] error: linking with uncompiled/unspecialized shader

bugzilla-daemon at freedesktop.org bugzilla-daemon at freedesktop.org
Sun Nov 4 10:21:27 UTC 2018


--- Comment #2 from madcatx at atlas.cz ---
I have recently run into this too and I have spent the better part of Saturday
trying to track this down, although unsuccessfully. FTR I noticed this issue as
some misrendering and missing transparency in KDE. It also makes Unigine:
Superposition benchmark abort. This is on a desktop machine with Radeon RX570.

As there were not that many changes between mesa 18.2.2 and 18.2.3 I tried to
bisect the issue to no avail. The weird part is that even when I build
mesa-18.2.2 from source I still get the "error: invalid input layout qualifier
used" failure message. I even went back to mesa-18.2.1 but I got the same
result. The only way how to "fix" this appears to be installation of
mesa-18.2.2 from official Fedora packages. Unless I have been doing something
terribly wrong I am starting to think that this may not be a mesa issue after

I have mesa-18.2.4 installed on my laptop with HD3000 GPU running Arch Linux
and it is all fine there.

The shader that KWin fails to compile is as simple as this:
#version 140

uniform mat4 colorMatrix;
uniform sampler2D sampler;
uniform float opacity;
noperspective in vec4 varyingTexCoords;
out vec4 fragColor;

void main(void)
    vec4 tex = texture(sampler, varyingTexCoords.st);
    if (opacity >= 1.0) {
        fragColor = tex * colorMatrix;
    } else {
        fragColor = tex * (opacity * colorMatrix + (1.0 - opacity) *

You are receiving this mail because:
You are the QA Contact for the bug.
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.freedesktop.org/archives/intel-3d-bugs/attachments/20181104/7d903c04/attachment.html>

More information about the intel-3d-bugs mailing list