[Intel-gfx] KMS, GEM and 2.6.30-rc1

Adam Lantos hege at playma.org
Thu Apr 9 20:08:33 CEST 2009


I also ran into something similar with my i915 using after
boot, the screen goes blank, but the system boots up correctly in the
background. First I suspected that it sets the wrong resolution, but
kernel log showed that LVDS native resolution was set, and also
reported no errors/warnings about that.

What's the status of the latest intel patches you mentioned? The
latest release from the 2.6 branch (2.6.3) is more than 5 weeks old,
and 4 weeks passed since the last -rc...


On Thu, Apr 9, 2009 at 6:55 PM, Jesse Barnes <jbarnes at virtuousgeek.org> wrote:
> On Thu, 9 Apr 2009 16:56:11 +0300
> "Claudio M. Camacho" <claudiomkd at gmail.com> wrote:
>> On Thursday 09 April 2009 10:03:46 Jake wrote:
>> > I am currently running 2.6.29, KMS on GM45, and it's pretty stable.
>> > To get things
>> > working I needed to add the following boot flag:
>> >
>> > i915.modeset=1
>> >
>> > Otherwise I would get corrupted terminals and could not exit X
>> > without freezing.
>> Well, I am, of course, using i915.modeset=1 and my configuration is
>> the same as yours, pretty much empty, apart from the UXA accel
>> method. But still, X hangs as soon as KDM is started. In fact, even
>> if I just boot without KDM and run Xorg or xinit or startx, X hangs
>> in the same way.
>> Furthermore, and as I already explained in my first email, even with
>> modesetting enabled, I see an annoying mode switch when I run Xorg
>> (or xinit or startx) before the hang. And, if it helps, the computer
>> totally freezes, not just X (even power button does not do anything,
>> which means acpid is also dead).
> There's a bug open for this issue and a test patch available:
> https://bugs.freedesktop.org/show_bug.cgi?id=21077
>> If nobody has a clue, I will have to file a bug, since this has been
>> happening for two months already.
> Does the 'modetest' program work for you?  It's part of the drm repo...
> Also have you tried git master of the xf86-video-intel driver?  AFAIK
> 2.6.3 should work ok but there have been many fixes added since then.
> Also be sure all your package versions will work together, Carl
> recently ran into an issue where one or more was incompatible (silently
> unfortunately) leading to a hard hang at server startup.
> Another thing to try is a totally stripped down session.  I.e. boot
> into console mode only (with the new KMS console), and start X with
> just an xterm (e.g. echo "exec xterm" > .xinitrc; startx).  It'll help
> narrow things down.
> --
> Jesse Barnes, Intel Open Source Technology Center
> _______________________________________________
> Intel-gfx mailing list
> Intel-gfx at lists.freedesktop.org
> http://lists.freedesktop.org/mailman/listinfo/intel-gfx

More information about the Intel-gfx mailing list