[Intel-gfx] [PATCH] Require xserver 1.3

Rémi Cardona remi at gentoo.org
Sat Apr 18 20:43:42 CEST 2009

Le 17/04/2009 22:13, Eric Anholt a écrit :
> OK, but do you need this for building 2.8 on RHEL5?  Or can we safely
> delete?  My opinion at this point is that for 2.8 (june) we should
> remove pre-server 1.6 support as nobody would be shipping 2.8 against a
> server older than that.

For the record, we (Gentoo) just got around to shipping 1.5.3 as a 
stable X. Would it be hard to maintain 2.7 as a "longer than usual" 
stable branch? Would I be the only downstream maintainer interested in that?

I'm just speaking hypothetically here, since I definitely want Gentoo to 
catch up to current X versions instead of lagging a year (or four) behind.

> I mean, if we're removing DRI1 support in 2.8, then you wouldn't want
> 2.8 pre server 1.6 anyway.

FWIW, for all versions past 2.4, users reporting bugs for -intel against 
server 1.3 (our previously stable version) were all asked to reproduce 
the bug against 1.4 or 1.5. All those bugs were fixed with the upgrade.

If the plan is just raise the server bar a little, I would put 1.4 as 
the strictest minimum.

But in the end, I guess doing the major clean-up is going to be better 
for everybody, including us Gentoo lads.



More information about the Intel-gfx mailing list