[Intel-gfx] [PATCH 1/2] drm/i915: Rename GGTT init functions
joonas.lahtinen at linux.intel.com
Thu Mar 24 07:40:03 UTC 2016
On ke, 2016-03-23 at 18:02 +0200, Ville Syrjälä wrote:
> On Wed, Mar 23, 2016 at 05:54:09PM +0200, Mika Kuoppala wrote:
> > Ville Syrjälä <ville.syrjala at linux.intel.com> writes:
> > >
> > > [ text/plain ]
> > > On Wed, Mar 23, 2016 at 03:00:22PM +0200, Joonas Lahtinen wrote:
> > > >
> > > > Rename and document the GGTT init functions to give a better
> > > > idea of the context where they are called from.
> > > >
> > > > i915_gem_gtt_init => i915_init_ggtt_hw
> > > Seems to me i915_ggtt_init_hw would match existing practices better.
> > >
> > There is also some gravity towards putting the verb first. In gem
> > side atleast.
> At least in this case ggtt_init_hw would match ppgtt_init_hw, which
> seems like a nice thing.
Right, I have changed the order quite a few times already. If it's
i915_init_* (like i915_init_userptr), will be easier to grep.
Adding Chris here as we discussed this yesterday. His idea is that
logic should be action_feature and object_verb, init_some_thingamagic,
Whatever we decide on, we should drop a small note at kerneldoc.
Open Source Technology Center
More information about the Intel-gfx