[Intel-gfx] [PATCH 1/2] drm/i915: Rename some warts in the VMA API

Joonas Lahtinen joonas.lahtinen at linux.intel.com
Mon Jan 16 11:34:02 UTC 2017

On ma, 2017-01-16 at 09:49 +0000, Chris Wilson wrote:
> Whilst writing testcases to exercise the VMA API, some oddities came to
> light, such as i915_gem_obj_lookup_or_create(). Joonas suggested
> i915_vma_instance() as a neat replacement, so rename them, move them to
> i915_vma.c  and add some kerneldoc as a sugary bonus.
> s/i915_gem_obj_to_vma/i915_vma_lookup/
> s/i915_gem_obj_lookup_or_create_vma/i915_vma_instance/
> Suggested-by: Joonas Lahtinen <joonas.lahtinen at linux.intel.com>
> Signed-off-by: Chris Wilson <chris at chris-wilson.co.uk>
> Cc: Joonas Lahtinen <joonas.lahtinen at linux.intel.com>
> Cc: Tvrtko Ursulin <tvrtko.ursulin at intel.com>


> +/**
> + * i915_vma_lookup - finds a matching VMA
> + * @obj - parent  &drm_i915_gem_object to be mapped

Before this circles back from the code checkers; s/ - /: /g

Also extra space, and not sure if it was supposed to always be
"&struct foo"?

Didn't spot anything else, so with kerneldoc fixed;

Reviewed-by: Joonas Lahtinen <joonas.lahtinen at linux.intel.com>

Regards, Joonas
Joonas Lahtinen
Open Source Technology Center
Intel Corporation

More information about the Intel-gfx mailing list