[Intel-gfx] [PATCH v6 00/10] GuC Scrub vol. 1

Arkadiusz Hiler arkadiusz.hiler at intel.com
Thu Mar 2 16:03:44 UTC 2017


General GuC/HuC cleanup simplifying logic, and moving chunks around as the area
got pretty rusty.

A lot of logic were extracted from intel_guc_load() to other functions - it did
not only handle the actual loading but had WA implementations and the code
that enabled submission baked into it.

This is the first part of effort to clean it up.

v2: rebase after HuC merge + feedback
v3: even more renaming that aims to make things more semantic
v4: some naming improvements, some bikeshedding
v5: coding style, some cleanup
    module params for huc and guc firmware path,
    separate fw select step from actual prepare
v6: feedback + pushed a couple of patches with r-b down the stack

Arkadiusz Hiler (10):
  drm/i915/uc: Rename intel_?uc_{setup,load}() to _init_hw()
  drm/i915/uc: Drop superfluous externs in intel_uc.h
  drm/i915/huc: Add huc_to_i915
  drm/i915/uc: Move intel_uc_fw_fetch() to intel_uc.c
  drm/i915/uc: Introduce intel_uc_init_fw()
  drm/i915/guc: Extract param logic form guc_init_fw()
  drm/i915/guc: Simplify intel_guc_init_hw()
  drm/i915/uc: Simplify firmware path handling
  drm/i915/uc: Separate firmware selection and preparation
  drm/i915/uc: Add params for specifying firmware

 drivers/gpu/drm/i915/i915_drv.c         |   5 +-
 drivers/gpu/drm/i915/i915_drv.h         |   5 +
 drivers/gpu/drm/i915/i915_gem.c         |   2 +-
 drivers/gpu/drm/i915/i915_params.c      |  10 +
 drivers/gpu/drm/i915/i915_params.h      |   2 +
 drivers/gpu/drm/i915/intel_guc_loader.c | 367 ++++----------------------------
 drivers/gpu/drm/i915/intel_huc.c        |  69 +++---
 drivers/gpu/drm/i915/intel_uc.c         | 291 +++++++++++++++++++++++++
 drivers/gpu/drm/i915/intel_uc.h         |  25 ++-
 9 files changed, 395 insertions(+), 381 deletions(-)

-- 
2.9.3



More information about the Intel-gfx mailing list