[Intel-gfx] [PATCH 1/1] drm/i915/guc: s/intel_guc_fw_upload/intel_guc_init_hw/
Sagar Arun Kamble
sagar.a.kamble at intel.com
Thu Mar 1 10:28:03 UTC 2018
On 3/1/2018 3:36 PM, Michal Wajdeczko wrote:
> On Thu, 01 Mar 2018 09:18:18 +0100, Sagar Arun Kamble
> <sagar.a.kamble at intel.com> wrote:
>> GuC and HuC get loaded from intel_uc_init_hw. HuC load function is
>> named intel_huc_init_hw, however GuC load function is still named in
>> old style as intel_guc_fw_upload. Update it and the function doc. for
>> both functions.
>> Move of GuC load function's def. & decl. to intel_guc.c|h seems
>> as it is more about core GuC functionality and not so much about fw
>> This can be done in later patch if needed.
> Function intel_guc_fw_upload() was named this way on purpose to follow
> object-verb naming pattern, where our object is GuC FW (hence file name
> There was a plan to unify this approach with HuC but in the opposite way:
> by moving HuC firmware selection code to intel_huc_fw.* but since only
> one function will be left in intel_huc.c this action was deferred.
Thanks for background on this.
> Note that there will be nothing wrong to call fw_upload functions from
> our uc_init_hw function:
Will just do HuC name change (s/intel_huc_init_hw/intel_huc_fw_upload/)
and comments update. HuC related move can be done later.
Is that ok?
More information about the Intel-gfx