[Intel-gfx] [PATCH 0/7] drm/i915: move dpll_info inside intel_shared_dpll

Lucas De Marchi lucas.demarchi at intel.com
Tue Mar 20 06:24:16 UTC 2018


This is an alternative to my previous patch
"drm/i915: Remove hole and padding from intel_shared_dpll".

Not sure if I split this too much, but I think it's easier to review
this way. We can always squash them if wanted.

As can be seen below this reduces .text and size of our structs, but
maybe more important it puts the const data together. 

   text	   data	    bss	    dec	    hex	filename
1753856	  69541	   5316	1828713	 1be769	drivers/gpu/drm/i915/i915.ko
1753668	  69541	   5316	1828525	 1be6ad	drivers/gpu/drm/i915/i915.ko.new

Ville, instead of adding a pointer I decided to copy the struct, just
because I thought we were going through too many indirections while for
example accesssing pll->info->funcs->get_hw_state().

struct sizes:
		       before	after
intel_shared_dpll	  152	  128
i915_drm_private	32112	31968

Lucas De Marchi (7):
  drm/i915: move dpll_info to header
  drm/i915: embed dpll_info inside intel_shared_dpll
  drm/i915: use funcs from dpll_info embedded in intel_shared_dpll
  drm/i915: use name from dpll_info embedded in intel_shared_dpll
  drm/i915: use id from dpll_info embedded in intel_shared_dpll
  drm/i915: use flags from dpll_info embedded in intel_shared_dpll
  drm/i915: rename dpll_info to intel_dpll_info

 drivers/gpu/drm/i915/i915_debugfs.c   |   3 +-
 drivers/gpu/drm/i915/intel_ddi.c      |   8 +-
 drivers/gpu/drm/i915/intel_display.c  |  25 ++---
 drivers/gpu/drm/i915/intel_dpll_mgr.c | 198 +++++++++++++++++-----------------
 drivers/gpu/drm/i915/intel_dpll_mgr.h |  53 +++++----
 5 files changed, 145 insertions(+), 142 deletions(-)

-- 
2.14.3



More information about the Intel-gfx mailing list