[Intel-gfx] [PATCH 3/3] drm/i915/panel: mass rename functions to have intel_panel_ prefix

Ville Syrjälä ville.syrjala at linux.intel.com
Fri May 14 17:20:39 UTC 2021


On Wed, May 12, 2021 at 04:30:46PM +0300, Jani Nikula wrote:
> Follow the usual naming conventions. Also pull HAS_GMCH() check to
> intel_panel_fitting(). No functional changes.
> 
> Signed-off-by: Jani Nikula <jani.nikula at intel.com>
> ---
>  drivers/gpu/drm/i915/display/icl_dsi.c     |  4 ++--
>  drivers/gpu/drm/i915/display/intel_dp.c    |  9 +++-----
>  drivers/gpu/drm/i915/display/intel_dvo.c   |  2 +-
>  drivers/gpu/drm/i915/display/intel_hdmi.c  |  2 +-
>  drivers/gpu/drm/i915/display/intel_lvds.c  |  7 ++----
>  drivers/gpu/drm/i915/display/intel_panel.c | 25 ++++++++++++++++------
>  drivers/gpu/drm/i915/display/intel_panel.h |  8 +++----
>  drivers/gpu/drm/i915/display/vlv_dsi.c     |  7 ++----
>  8 files changed, 32 insertions(+), 32 deletions(-)
> 
> diff --git a/drivers/gpu/drm/i915/display/icl_dsi.c b/drivers/gpu/drm/i915/display/icl_dsi.c
> index da1b00859f3b..024b2e2107d5 100644
> --- a/drivers/gpu/drm/i915/display/icl_dsi.c
> +++ b/drivers/gpu/drm/i915/display/icl_dsi.c
> @@ -1594,9 +1594,9 @@ static int gen11_dsi_compute_config(struct intel_encoder *encoder,
>  	int ret;
>  
>  	pipe_config->output_format = INTEL_OUTPUT_FORMAT_RGB;
> -	intel_fixed_panel_mode(fixed_mode, adjusted_mode);
> +	intel_panel_fixed_mode(fixed_mode, adjusted_mode);
>  
> -	ret = intel_pch_panel_fitting(pipe_config, conn_state);
> +	ret = intel_panel_fitting(pipe_config, conn_state);
>  	if (ret)
>  		return ret;
>  
> diff --git a/drivers/gpu/drm/i915/display/intel_dp.c b/drivers/gpu/drm/i915/display/intel_dp.c
> index efb7a249393c..5624f3fad859 100644
> --- a/drivers/gpu/drm/i915/display/intel_dp.c
> +++ b/drivers/gpu/drm/i915/display/intel_dp.c
> @@ -1652,7 +1652,7 @@ intel_dp_compute_config(struct intel_encoder *encoder,
>  							    adjusted_mode);
>  
>  	if (pipe_config->output_format == INTEL_OUTPUT_FORMAT_YCBCR420) {
> -		ret = intel_pch_panel_fitting(pipe_config, conn_state);
> +		ret = intel_panel_fitting(pipe_config, conn_state);
>  		if (ret)
>  			return ret;
>  	}
> @@ -1665,13 +1665,10 @@ intel_dp_compute_config(struct intel_encoder *encoder,
>  		pipe_config->has_audio = intel_conn_state->force_audio == HDMI_AUDIO_ON;
>  
>  	if (intel_dp_is_edp(intel_dp) && intel_connector->panel.fixed_mode) {
> -		intel_fixed_panel_mode(intel_connector->panel.fixed_mode,
> +		intel_panel_fixed_mode(intel_connector->panel.fixed_mode,
>  				       adjusted_mode);
>  
> -		if (HAS_GMCH(dev_priv))
> -			ret = intel_gmch_panel_fitting(pipe_config, conn_state);
> -		else
> -			ret = intel_pch_panel_fitting(pipe_config, conn_state);
> +		ret = intel_panel_fitting(pipe_config, conn_state);

Hmm. I though there was something a bit more subtle going on here...
Ah, I think I'm recalling the tv margin stuff that's still sitting
in my branch. That will need to make a bit of distinction between
gmch vs. not here, but this should be fine even then.

Series is more or less
Reviewed-by: Ville Syrjälä <ville.syrjala at linux.intel.com>
(didn't read the code motion patch too closely).

-- 
Ville Syrjälä
Intel


More information about the Intel-gfx mailing list