[PATCH 0/6] drm/i915/lspcon: interface cleanups
Jani Nikula
jani.nikula at intel.com
Tue Dec 3 16:40:50 UTC 2024
Some quick cleanups. Always use digital port for the interfaces, don't
touch dig_port->lspcon outside of intel_lspcon.c, rename interfaces.
Jani Nikula (6):
drm/i915/hdmi: move declarations for hsw_read/write_infoframe() to the
right place
drm/i915/lspcon: add intel_lspcon_active() and use it
drm/i915/lspcon: change signature of lspcon_detect_hdr_capability()
drm/i915/lspcon: change signature of lspcon_wait_pcon_mode()
drm/i915/lspcon: remove dp_to_lspcon(), hide enc_to_intel_lspcon()
drm/i915/lspcon: rename interfaces to intel_lspcon_* to unify
drivers/gpu/drm/i915/display/intel_ddi.c | 6 ++---
.../drm/i915/display/intel_display_types.h | 12 ---------
drivers/gpu/drm/i915/display/intel_dp.c | 18 ++++++-------
drivers/gpu/drm/i915/display/intel_hdmi.h | 9 +++++++
drivers/gpu/drm/i915/display/intel_lspcon.c | 27 +++++++++++++++----
drivers/gpu/drm/i915/display/intel_lspcon.h | 25 +++++++----------
6 files changed, 51 insertions(+), 46 deletions(-)
--
2.39.5
More information about the Intel-gfx
mailing list