[PATCH v3 3/4] drm/xe/guc: Rename CONFIG_XE_LARGE_GUC_BUFFER
Michal Wajdeczko
michal.wajdeczko at intel.com
Thu May 8 19:52:51 UTC 2025
On 08.05.2025 03:34, John.C.Harrison at Intel.com wrote:
> From: John Harrison <John.C.Harrison at Intel.com>
>
> Rename XE_LARGE_GUC_BUFFER to XE_DEBUG_GUC to allow for more debug
> only code (in subsequent patch) without adding more config defines
> that each control only a single thing.
>
> Signed-off-by: John Harrison <John.C.Harrison at Intel.com>
Reviewed-by: Michal Wajdeczko <michal.wajdeczko at intel.com>
> ---
> drivers/gpu/drm/xe/Kconfig.debug | 8 +++++---
> drivers/gpu/drm/xe/xe_guc_log.h | 2 +-
> 2 files changed, 6 insertions(+), 4 deletions(-)
>
> diff --git a/drivers/gpu/drm/xe/Kconfig.debug b/drivers/gpu/drm/xe/Kconfig.debug
> index 0d749ed44878..db063a513b1e 100644
> --- a/drivers/gpu/drm/xe/Kconfig.debug
> +++ b/drivers/gpu/drm/xe/Kconfig.debug
> @@ -86,12 +86,14 @@ config DRM_XE_KUNIT_TEST
>
> If in doubt, say "N".
>
> -config DRM_XE_LARGE_GUC_BUFFER
> - bool "Enable larger guc log buffer"
> +config DRM_XE_DEBUG_GUC
> + bool "Enable extra GuC related debug options"
> + depends on DRM_XE_DEBUG
> default n
> help
> Choose this option when debugging guc issues.
> - Buffer should be large enough for complex issues.
> + The GuC log buffer is increased to the maximum allowed, which should
> + be large enough for complex issues.
>
> Recommended for driver developers only.
>
> diff --git a/drivers/gpu/drm/xe/xe_guc_log.h b/drivers/gpu/drm/xe/xe_guc_log.h
> index 5b896f5fafaf..f1e2b0be90a9 100644
> --- a/drivers/gpu/drm/xe/xe_guc_log.h
> +++ b/drivers/gpu/drm/xe/xe_guc_log.h
> @@ -12,7 +12,7 @@
> struct drm_printer;
> struct xe_device;
>
> -#if IS_ENABLED(CONFIG_DRM_XE_LARGE_GUC_BUFFER)
> +#if IS_ENABLED(CONFIG_DRM_XE_DEBUG_GUC)
> #define CRASH_BUFFER_SIZE SZ_1M
> #define DEBUG_BUFFER_SIZE SZ_8M
> #define CAPTURE_BUFFER_SIZE SZ_2M
More information about the Intel-xe
mailing list