[PATCH 01/18] drm/i915/dpll: Rename intel_dpll
Jani Nikula
jani.nikula at linux.intel.com
Fri May 9 10:04:18 UTC 2025
On Fri, 09 May 2025, Suraj Kandpal <suraj.kandpal at intel.com> wrote:
> Rename intel_dpll to intel_dpll_global so that intel_shared_dpll
> can be renamed to intel_dpll in an effort to move away from the shared
> naming convention.
> Also intel_dpll according to it's comment tracks global dpll rather
> than individual hence making more sense this gets changed.
>
> Signed-off-by: Suraj Kandpal <suraj.kandpal at intel.com>
Reviewed-by: Jani Nikula <jani.nikula at intel.com>
> ---
> drivers/gpu/drm/i915/display/intel_display_core.h | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/drivers/gpu/drm/i915/display/intel_display_core.h b/drivers/gpu/drm/i915/display/intel_display_core.h
> index b4937e102360..6fc213f84e73 100644
> --- a/drivers/gpu/drm/i915/display/intel_display_core.h
> +++ b/drivers/gpu/drm/i915/display/intel_display_core.h
> @@ -122,7 +122,7 @@ struct intel_audio {
> * intel_{prepare,enable,disable}_shared_dpll. Must be global rather than per
> * dpll, because on some platforms plls share registers.
> */
> -struct intel_dpll {
> +struct intel_dpll_global {
> struct mutex lock;
>
> int num_shared_dpll;
> @@ -570,7 +570,7 @@ struct intel_display {
> /* Grouping using named structs. Keep sorted. */
> struct drm_dp_tunnel_mgr *dp_tunnel_mgr;
> struct intel_audio audio;
> - struct intel_dpll dpll;
> + struct intel_dpll_global dpll;
> struct intel_fbc *fbc[I915_MAX_FBCS];
> struct intel_frontbuffer_tracking fb_tracking;
> struct intel_hotplug hotplug;
--
Jani Nikula, Intel
More information about the Intel-xe
mailing list