[Libdlo] Current Code location?

Alexander Todorov atodorov at otb.bg
Fri Jun 10 00:21:47 PDT 2011

На 10.06.2011 06:09, Matt Dorsch написа:
> Good evening,
>     I've purchased a DL device, and I'm attempting to use it with
> Fedora 15. I'm having some issues, but the biggest issue is this:
> which drivers/versions should I be using? There are four on the howto
> page, newer versions of some in various blog postings, and the udlfb
> module in the kernel. If I want to get X running single head, where
> should I begin?

Hi Matt,
IMHO you should either use udlfb from git.plugable.com (probably slightly 
outdated ATM) or udlfb from kernel.org. Nothing else.

>     I have had partial success, but with the window managers I've
> tried, I have the issues below. All packages are the latest in Fedora
> 15.
> Gnome: Gives a graphical error message on the DL screen and then exits.
> XFCE: The start menu doesn't open when you click on it. If you get a
> window open, it's confined to the upper left corner of the screen.
> KDE: Works almost completely, except for the pull-down menus not
> appearing in Klondike. (Click on File, Help, etc, and you'll get a
> horizontal line at the left of the screen, but no text.) The start
> menu works, and the menus in another application work.

I have had a similar issue long time ago. But it was in GNOME/GTK apps. Menus 
were drawn as small horizontal line, while QT apps were OK. That was on a RHEL 5 
box with a very very old version of udlfb. Updating to the latest (at that time) 
fixed it for me.

Just FYI: I was not able to debug this in details but I found out that menus 
were drawn as rectangles with negative height. I wasn't able to dig any deeper.


More information about the Libdlo mailing list