[Libdlo] Current Code location?

Matt Dorsch libdlo at dorscm.wakeful.net
Fri Jun 10 05:37:05 PDT 2011


Thank you for your response. I do have two follow questions however.

1. Where is the recommended X driver? Should I be using
http://git.plugable.com/webdav/xf-video-udlfb for that?

2. When you recommend using udlfb from kernel.org, you mean I should
use the one distributed with the kernel, assuming the kernel is
>=2.6.38? (I'm planning on updating the libdlo HowTo page, and I want
to make sure I don't make things worse.)

Finally, with respect to the applications, I've tried XFCE and Gnome
using the VESA driver on the internal graphics adapter, an NVidia
GeForce TI 4400. Gnome ran in its Safe Mode, but still worked. XFCE
had no issues at all.


On Fri, Jun 10, 2011 at 3:21 AM, Alexander Todorov <atodorov at otb.bg> wrote:
> На 10.06.2011 06:09, Matt Dorsch написа:
>> Good evening,
>>    I've purchased a DL device, and I'm attempting to use it with
>> Fedora 15. I'm having some issues, but the biggest issue is this:
>> which drivers/versions should I be using? There are four on the howto
>> page, newer versions of some in various blog postings, and the udlfb
>> module in the kernel. If I want to get X running single head, where
>> should I begin?
> Hi Matt,
> IMHO you should either use udlfb from git.plugable.com (probably slightly
> outdated ATM) or udlfb from kernel.org. Nothing else.
>>    I have had partial success, but with the window managers I've
>> tried, I have the issues below. All packages are the latest in Fedora
>> 15.
>> Gnome: Gives a graphical error message on the DL screen and then exits.
>> XFCE: The start menu doesn't open when you click on it. If you get a
>> window open, it's confined to the upper left corner of the screen.
>> KDE: Works almost completely, except for the pull-down menus not
>> appearing in Klondike. (Click on File, Help, etc, and you'll get a
>> horizontal line at the left of the screen, but no text.) The start
>> menu works, and the menus in another application work.
> I have had a similar issue long time ago. But it was in GNOME/GTK apps.
> Menus were drawn as small horizontal line, while QT apps were OK. That was
> on a RHEL 5 box with a very very old version of udlfb. Updating to the
> latest (at that time) fixed it for me.
> Just FYI: I was not able to debug this in details but I found out that menus
> were drawn as rectangles with negative height. I wasn't able to dig any
> deeper.
> --
> Alexander.

More information about the Libdlo mailing list