greg/proxy merged to git master

Dan Williams dcbw at
Fri Aug 1 09:56:55 PDT 2014

On Fri, 2014-08-01 at 09:20 +0200, Aleksander Morgado wrote:
> On Fri, Aug 1, 2014 at 5:31 AM, Dan Williams <dcbw at> wrote:
> >> Just merged the greg/proxy branch to git master, so that the
> >> mbim-proxy goes in the next release.
> >
> > So I ran some quick tests today with both ModemManager running (hacked
> > to request the proxy on device_open()) and mbimcli and I did run into
> > some problems.  I was just doing "mmcli -m 0" and "mbimcli
> > --query-subscriber-ready-status", and my device did not have a SIM
> > inserted, so the --query-subscriber-ready-status should have returned
> > "no sim inserted".
> >
> > I ran the proxy with -v to watch the traffic; I noticed that I'd get a
> > lot of "transaction ID not found" errors, and often the mbimcli command
> > would time out.  Has anyone else seen that?
> Are you running the mbimcli command with "--device-open-proxy" (or
> just -p)? Those symptoms are really what you would expect when not
> running the mbimcli through the proxy.

You know, I'm sure I was originally.  But then perhaps I didn't.  In any
case, I cannot reproduce the issue anymore.


More information about the libmbim-devel mailing list