Sierra Wireless EM7455, MBIM connect

Fabian Schörghofer fabian.schoergi at
Fri Apr 15 09:27:15 UTC 2016

I have a Sierra Wireless EM7455. It is supposedly in MBIM mode, as the
dmesg output shows a new /dev/cdc-wdm0 device, and wwan0 with mbim.
The device is not from a Lenovo notebook. Firmware is

I know that during this device is using rawip to transmit data, which
only works on newer kernels, I got kernel 4.6.0 rc2 running.

I tried to connect with the following commands:

mbimcli -d /dev/cdc-wdm0 --register-automatic
mbimcli -d /dev/cdc-wdm0

(no user/pw is required)

But then I do not know if I am connected and how to assign the IP to wwan0.
dhclient -i wwan0 is not working.

I try to avoid using ModemManager or Networkmanager to connect, as I
might not have those installed on the device I plan to use it.
Nevertheless I tried connecting with:

mmcli -m 1 --simple-connect=",ip-type=ipv4"

but no result either. Not sure about the ipv4 type, or if its just plain "ip".

On some forums I heared that it is possible to switch the device to
QMI, is this the better/more elegant way to connect the device, and
how can the device be changed? Some AT-command?

Best Regards

More information about the libmbim-devel mailing list