EM7455 on Lenovo Thinkpad T460s

Daniel Barlow dan at telent.net
Mon Mar 27 09:47:25 UTC 2017

You say you've tried the usual suggestions so I won't reiterate them.  I
had more fun than I really wanted getting the 7455 to work on my setup (X1
Carbon), which eventually turned out to be because the standard version of
qmictl in NixOS was not built against libmbim, meaning that it didn't know
how to do the FCC auth call.  I don;t know if the Ubuntu packages are
similar. Try

ldd `type -p qmictl` |grep mbim

and check it's pointing at libmbim

On 27 March 2017 at 10:35, Aleksander Morgado <aleksander at aleksander.es>

> On Mon, Mar 27, 2017 at 11:10 AM, Killian Keller
> <keller.killian at gmail.com> wrote:
> > Did you manage to successfully create a connection with the EM7455? I
> read
> > through the mailing list, tried most of the suggestions, but nothing
> seems
> > to work for me. Could you point me in the correct direction? I have been
> > trying to get it to work for the last two weeks (and it even worked for
> half
> > an hour, with an Live-USB of Ubuntu) but I do not get any progress.
> >
> > I work on a Lenovo Thinkpad T460s, the wwan module is a Sierra Wireless
> > EM7455. The operating system is Ubuntu 16.04, kernel is
> 4.8.0-43-lowlatency.
> > ModemManager version 1.6.0, qmicli 1.12.6, mbimcli 1.14.0. No special
> > branches used.
> Could be due to this? https://bugs.freedesktop.org/show_bug.cgi?id=100001
> That will be fixed in the next 1.6.x release, which we should probably
> already do... I'll also push it to my unofficial 16.04 PPA here, in
> case you want to add it already:
> https://launchpad.net/~aleksander-m/+archive/ubuntu/modemmanager-xenial
> Although in that bug report the setup was working in QMI mode IIRC.
> Anyway, if you could gather ModemManager debug logs, we can probably
> confirm whether the issue is the same or not:
> https://www.freedesktop.org/wiki/Software/ModemManager/Debugging/
> --
> Aleksander
> https://aleksander.es
> _______________________________________________
> libmbim-devel mailing list
> libmbim-devel at lists.freedesktop.org
> https://lists.freedesktop.org/mailman/listinfo/libmbim-devel

dan at telent.net
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.freedesktop.org/archives/libmbim-devel/attachments/20170327/56cd7ffe/attachment.html>

More information about the libmbim-devel mailing list