EM7455 on Lenovo Thinkpad T460s

Tim Harvey tharvey at gateworks.com
Mon Mar 27 13:13:07 UTC 2017

On Mon, Mar 27, 2017 at 2:10 AM, Killian Keller <keller.killian at gmail.com>

> Hi guys,
> Did you manage to successfully create a connection with the EM7455? I read
> through the mailing list, tried most of the suggestions, but nothing seems
> to work for me. Could you point me in the correct direction? I have been
> trying to get it to work for the last two weeks (and it even worked for
> half an hour, with an Live-USB of Ubuntu) but I do not get any progress.
> I work on a Lenovo Thinkpad T460s, the wwan module is a Sierra Wireless
> EM7455. The operating system is Ubuntu 16.04, kernel is
> 4.8.0-43-lowlatency. ModemManager version 1.6.0, qmicli 1.12.6, mbimcli
> 1.14.0. No special branches used.

I got my EM7455 working with Linux 4.10, libmbim-1.14.0, and
libqmi-1.17.901. I did not use ModemManager as I was more interested in how
things worked with a manual configuration. There were some key points:
- Lenovo EM7455 (1199:9079) uses MBIM
- I needed to enable FCC auth using 'qmicli -d /dev/cdc-wdm0
--device-open-mbim --dms-set-fcc-authentication' (verify radio is enabled
in both hw/sw states via 'mbimcli -d /dev/cdc-wdm0 --query-radio-state')

I would recommend building a local updated libmbim/libqmi from source which
is fairly straight-forward.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.freedesktop.org/archives/libmbim-devel/attachments/20170327/2f63048e/attachment.html>

More information about the libmbim-devel mailing list