[RFC] Bumping minimum glib2 required version to 2.48

Aleksander Morgado aleksander at aleksander.es
Fri Jan 10 14:05:09 UTC 2020

Hey Dan & all!

I'm thinking in bumping the minimum glib2 required version from 2.36
to 2.48 in all libmbim, libqmi and ModemManager, in order to be able
to start using e.g. G_DECLARE_FINAL_TYPE(),
G_DECLARE_DERIVABLE_TYPE(), g_autoptr() and such.

GLib 2.48.0 was released on Mar 22nd 2016.



More information about the libmbim-devel mailing list