[RFC] Bumping minimum glib2 required version to 2.48

Dan Williams dcbw at redhat.com
Fri Jan 10 15:30:09 UTC 2020

On Fri, 2020-01-10 at 15:05 +0100, Aleksander Morgado wrote:
> Hey Dan & all!
> I'm thinking in bumping the minimum glib2 required version from 2.36
> to 2.48 in all libmbim, libqmi and ModemManager, in order to be able
> to start using e.g. G_DECLARE_FINAL_TYPE(),
> G_DECLARE_DERIVABLE_TYPE(), g_autoptr() and such.
> GLib 2.48.0 was released on Mar 22nd 2016.

Works for me, and all the OS versions I care a bunch about (Fedora,
RHEL) have 2.48 for a long time.

I assume this lets us get rid of the autoptr hacks I put in a while


More information about the libmbim-devel mailing list