[RFC] Bumping minimum glib2 required version to 2.48
aleksander at aleksander.es
Fri Jan 10 17:51:49 UTC 2020
> > I'm thinking in bumping the minimum glib2 required version from 2.36
> > to 2.48 in all libmbim, libqmi and ModemManager, in order to be able
> > to start using e.g. G_DECLARE_FINAL_TYPE(),
> > G_DECLARE_DERIVABLE_TYPE(), g_autoptr() and such.
> > GLib 2.48.0 was released on Mar 22nd 2016.
> Works for me, and all the OS versions I care a bunch about (Fedora,
> RHEL) have 2.48 for a long time.
> I assume this lets us get rid of the autoptr hacks I put in a while
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the libmbim-devel