mbimcli use from a NON ROOTuser

Roman Rozman rozmanro at gmail.com
Tue Aug 16 07:13:40 UTC 2022

Hi all,

Would like to ask if running the mbimcli from *other than root user* on a
Linux system is possible?
Because from root all works fine, but from other user on the system the
execution is getting stuck and manually(ctrl+C) termination is needed to
stop the process.
I have tried multiple users other than root, same result.

*root user:*
[*root*@localhost ~]# mbimcli -p -d /dev/cdc-wdm0 --query-radio-state
[/dev/cdc-wdm0] Radio state retrieved:
             Hardware Radio State: 'on'
             Software Radio State: 'on'
[/dev/cdc-wdm0] Session not closed:
            TRID: '4'
[*root*@localhost ~]#

*custom user:*[*__cell*@localhost ~]$ /usr/bin/mbimcli -p -d /dev/cdc-wdm0

cancelling the operation...

error: couldn't open the MbimDevice: Transaction aborted
^C[*__cell*@localhost ~]$
[*__cell*@localhost ~]$

*mbimcli version:*
[root at localhost ~]# mbimcli -V

mbimcli 1.14.2
Copyright (2013-2014) Aleksander Morgado
License GPLv2+: GNU GPL version 2 or later <
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.

*My system:*CentOS Linux release 7.8 based on Linux Kernel 4.19.128 aarch64

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.freedesktop.org/archives/libmbim-devel/attachments/20220816/d3168191/attachment.htm>

More information about the libmbim-devel mailing list