Netgear 770S

Markus Gothe nietzsche at
Mon Oct 20 09:31:17 PDT 2014

Not even the CTL Set Data Format works…

I tried both by using qmicli and my home-brewed implementation (based on uqmi).
The latter one worked better than qmicli. :-/

So the mode stay consistent 9 times of 10.


On 20 Oct 2014, at 09:44 , Aleksander Morgado <aleksander at> wrote:

> On Fri, Oct 17, 2014 at 8:33 PM, Markus Gothe <nietzsche at> wrote:
>> This AT&T MiFi exposé a  QMI-interface when using USB-tethering in Linux.
>> It supports WDA, kinda. Netgear seems to have been defaulting to
>> 'raw-ip' lately.
>> Sometimes I am succesful to change the data format with qmicli. But it
>> works far from everytime.
> How does it fail? It just doesn't change the mode? After updating with
> qmicli, did you read the current value with qmicli as well?
> -- 
> Aleksander

//Markus - The panama-hat hacker

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 195 bytes
Desc: Message signed with OpenPGP using GPGMail
URL: <>

More information about the libqmi-devel mailing list