MC7430 ubuntu 16.04 or 16.10 and latest kernel

Ross Cruickshank ross.cruickshank at
Wed Dec 14 10:51:24 UTC 2016

I am trying to get the sierra wireless MC7430 in Ubuntu 16.04. I have
searched the list archive and can find that there has been some problems
with this card. However I cant even get it to actually load any interfaces.
I don't get the 3 serial ports at /dev/tttyUSB? nor /dev/cdc-wdm?
I have tried upgrading modemmanger to version 1.6 manually using dpkg -i
and installing the updated dependencies.

libmbim-glib4 (>= 1.12.2)
libmm-glib0 (>= 1.5.993)
libpolkit-gobject-1-0 (>= 0.99)
libqmi-glib5 (>= 1.14.0)
I also upgraded the kernel to 4.8.14
I have tried ubuntu 16.10 also.

I downloaded and installed the Gobi drivers from Sierra Wireless - Version
With this a single device /dev/ttyUSB0 appeared but nothing else. I have
since removed them because I wanted to use libqmi.

I should note that I am using a mini PCI-E to PCI-E +USB adapter card and
running it in a PCI-E x4 slot. This exact same set up is working with a
MC7304.  One difference would be that the MC7430 uses the USB 3.0 interface
when available, however the adaptor card only has USB2.0.

Has anyone had this working in Ubuntu?
Thank you


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the libqmi-devel mailing list