MC7430 ubuntu 16.04 or 16.10 and latest kernel

Westerhoff, Vincent Vincent.Westerhoff at
Wed Dec 14 11:51:17 UTC 2016

What does this command show?



If it shows 25 as answer you got no /cdc/wdmX and no network interface. Be sure to enter password first with AT!ENTERCND. I use kernel 4.1.15.


Vincent Westerhoff
P3 group

Cell:       +49 151 571 33 327
E-Mail:    Vincent.Westerhoff at

P3 telehealthcare GmbH
legal disclaimer, mandatory information and the P3 office addresses can be found at

-----Original Message-----
From: libqmi-devel [mailto:libqmi-devel-bounces at] On Behalf Of Bjørn Mork
Sent: Wednesday, December 14, 2016 12:43 PM
To: Ross Cruickshank
Cc: libqmi-devel at
Subject: Re: MC7430 ubuntu 16.04 or 16.10 and latest kernel

Ross Cruickshank <ross.cruickshank at> writes:

> Hello,
> I am trying to get the sierra wireless MC7430 in Ubuntu 16.04. I have
> searched the list archive and can find that there has been some
> problems with this card. However I cant even get it to actually load any interfaces.
> I don't get the 3 serial ports at /dev/tttyUSB? nor /dev/cdc-wdm?
> I have tried upgrading modemmanger to version 1.6 manually using dpkg
> -i and installing the updated dependencies.
> libmbim-glib4 (>= 1.12.2)
> libmbim-proxy
> libmm-glib0 (>= 1.5.993)
> libpolkit-gobject-1-0 (>= 0.99)
> libqmi-glib5 (>= 1.14.0)
> libqmi-proxy
> I also upgraded the kernel to 4.8.14
> I have tried ubuntu 16.10 also.

I believe it should work with a v4.8 kernel. But the modem is fully configurable.  Maybe it is using an identity we don't know?

What's the output of "lsusb -v"? Feel free to remove irrelevant devices and serial numbers etc.  I'm primarily interested in the modem device ID and which functions it is configured for (serial, qmi, mbim, etc).

libqmi-devel mailing list
libqmi-devel at

More information about the libqmi-devel mailing list