MC7430 ubuntu 16.04 or 16.10 and latest kernel

Bjørn Mork bjorn at
Thu Dec 15 08:37:26 UTC 2016

Ross Cruickshank <ross.cruickshank at> writes:

> Thanks for your quick reply sorry about the delay.  However I had to mess
> around with my kernel etc. I also think the problem lies with me using
> an adapter card and not a software/OS issue.
> Anyway I discovered I wasn't actually mounting at all i.e. no output from
> lsusb -v.  So I tried the modem in another PC box that
> had a mini-express port, and it worked fine with mounting all the serial
> devices. I have included the output.

Ah, right.  That's good. Much easier to debug problems when we have the
root cause. 

Your lsusb output looks fine and matches the expected default settings
for the MC74xx cards: qcdm, nmea, at, qmi, qmi

(yes, there are 2 QMI functions)

> This PC's mini pci-E slot does not support USB3 but it has failed back USB
> 2.0 successfully. This got me thinking that maybe the adapter card  which
> will
> be putting PCI-E data on the USB3 bins is casing a problem. So I may need
> to try taping of this pins on the modem.

Try that. Note that all the signals you need to mask are on odd numbered
pins, meaning that they are on the same side of the modem. And they are
only separated by ground pins, meaning that you can just mask them all
with a single continuous piece of tape.

You should also make sure that the USB2 connection to the adapter is
working, and that there aren't any wwan disable jumper or something like
that on the adapter.  It's a bit unexpected that the modem doesn't show
up as an USB2 device, even with the PCIe signal confusion.  I'd expect
that rather to cause a boot failure.  But maybe your BIOS is smart
enough to disable the PCIe slot?


More information about the libqmi-devel mailing list