EM7455 Firmware update

Monroe L. King Jr. monroe at teamprometheus.org
Sat Jun 17 05:47:21 UTC 2017

 I have tried to use a live usb running Ubuntu 16.04 with no luck
because these commands will not work! I'm more than just a bit
frustrated at this point at too why these commands are not found. I've
followed all the instructions I can find on the net and I've reinstalled
Ubuntu and even tried 17.04.

 sudo apt-get install qmi-firmware-update


 Nither of these commands are found! I followed instructions here

 And here

Re: Mobile Beacon RV build

Post by JimHelms ยป Thu Jun 15, 2017 8:20 pm
Try these commands:

Code: Select all

sudo apt-get update
sudo apt-get install qmi-firmware-update
sudo apt-get install libqmi-utils
sudo apt-get install libqmi

Then you will need to download the firmware binary Linux files for the
Sierra Em7455. Place the zipped file in a folder on your desktop and
extract it there. Then follow the other instructions.

The Vendor and Product codes for the EM7455 should be: Vendor=1199,

Therefore, using the Sierra Em7455 firmware from the link above, open a
new console from within the folder containing the firmware, and run:

Code: Select all

sudo qmi-firmware-update --update -d 1199:9079 --device-open-mbim
SWI9X30C_02.24.03.00.cwe SWI9X30C_02.24.03.00_Generic_002.021_000.nvu

As I mentioned earlier, there are far more qualified people to provide
advice and guidance for Linux. Anyone?

 The problem is both of these people are using USB Live same as I am but
these commands are not found for me!

 It's kinda nuts isn't it? I don't understand any help appreciated.


More information about the libqmi-devel mailing list