EM7455 Firmware update

Bjørn Mork bjorn at mork.no
Sat Jun 17 12:48:18 UTC 2017

"Monroe L. King Jr." <monroe at teamprometheus.org> writes:

>  I have tried to use a live usb running Ubuntu 16.04 with no luck
> because these commands will not work! I'm more than just a bit
> frustrated at this point at too why these commands are not found. I've
> followed all the instructions I can find on the net and I've reinstalled
> Ubuntu and even tried 17.04.
>  sudo apt-get install qmi-firmware-update
>  ./swi_usbcomp.pl
>  Nither of these commands are found! I followed instructions here
> https://zukota.com/sierra-wireless-em7455-how-to-enable-com-ports/

Those instructions include a specially prepared Ubuntu image, which I
guess includes the necessary tools.  The instructions won't work with
any other Linux installation.

Use the link at

  "Download and unpack the following image file: UbuntuLive.7z"

At your own risk, of course - I have never tried that image and cannot
certify that it is good.

A few random notes about the tools:

The firmware update tool will eventually be included in most Linux
distros, but it is very new and therefore not there yet, as Aleksander
already said.

The swi_usbcomp.pl script will never be part of any standard Linux
distro.  It is a simple "run-once" hack I wrote, and was never intended
to be a "tool" as such. It should however run just fine on any recent
Linux distro.  You just have to download it first. You can find it here:


But as I said: It was meant as a hack, and that is all it will ever
be...  Use at your own risk. I wrote it, but I don't recommend it ;-) I
only provide the link since there are already multiple copies floating
around, and I might as well make it easier to locate for those looking.

Note that I don't think anybody here has anything to do with the
zukota.com blog.


More information about the libqmi-devel mailing list