qmi-network fails to start

BenoƮt benoit at neviani.fr
Fri Oct 6 16:11:31 UTC 2017


I have a new computer with a Sierra MC/EM7455 but I got an issue to make
it work with qmi-network. (I am not using networkmanager on this

When I try a qmi-network /dev/cdc-wdm0 start
I got a "QMI protocol error (3): 'Internal' with a WDA Unsupported.

So I tried to activate 802-3 with --set-expected-data-format=802-3 but I
receive an error as well where it fails to open file

I tried to see if some mbimcli commands work and yes I am able to see
the radio state and all the information correctly, everything is ON.

I also tried to connect through mbimcli using --connect... and I receive
an error as well: operation failed: NotInitialized

But mbimcli --query-subscriber-ready-state is telling me that the Ready
State is "initialized" !

I remember in the past I got some similar issue and I am wondering if it
is due to mode use by default from the modem?

I wrote an udev rule to change the bBonfigurationValue but it
doesn't seems to work either...

If I try to modprobe -r cdc_mbim then I don't have /dec/cdc-wdm0

I know I am close as all mbim commands work and return good values but I
am unable to connect...either with mbicli or qmicli

Any tips?

Many thanks :) 

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 833 bytes
Desc: not available
URL: <https://lists.freedesktop.org/archives/libqmi-devel/attachments/20171006/f3738dc2/attachment.sig>

More information about the libqmi-devel mailing list