qmi-network fails to start

Aleksander Morgado aleksander at aleksander.es
Sat Oct 7 08:10:44 UTC 2017

> I have a new computer with a Sierra MC/EM7455 but I got an issue to make
> it work with qmi-network. (I am not using networkmanager on this
> computer).
> When I try a qmi-network /dev/cdc-wdm0 start
> I got a "QMI protocol error (3): 'Internal' with a WDA Unsupported.
> So I tried to activate 802-3 with --set-expected-data-format=802-3 but I
> receive an error as well where it fails to open file
> /sys/class/net..../qmi/raw_ip.
> I tried to see if some mbimcli commands work and yes I am able to see
> the radio state and all the information correctly, everything is ON.
> I also tried to connect through mbimcli using --connect... and I receive
> an error as well: operation failed: NotInitialized
> But mbimcli --query-subscriber-ready-state is telling me that the Ready
> State is "initialized" !

Your modem is in MBIM mode, and the fact that you can run qmicli is
only because it's doing QMI over MBIM.
You need to focus on trying to get it connected using MBIM, i.e.
mbim-network and mbimcli.

Which arguments are you giving to the mbimcli --connect call? Have you
tried mbim-network?


More information about the libqmi-devel mailing list