UIM Card Application State?

Nick B nickberry17 at icloud.com
Thu Oct 31 20:33:03 UTC 2019

Hey everyone,

I am hoping for some details on QMI_UIM_CARD_APPLICATION_STATEs

I have read this...

…but in particular, I am seeing QMI_UIM_CARD_APPLICATION_STATE_ILLEGAL with a particular SIM and would like to know what that means.

When running qmicli —uim-get-card-status I would see Card application state: illegal.  I tried powering the SIM off and on using qmicli which did not change anything.  I also tried power cycling the system and I did an AT!RMARESET on the modem after which the SIM surprisingly, albeit briefly (for about a minute or two) was visible in ModemManager as SIM/0 but eventually MM reported SIM missing.  After that, I would again see Application State: illegal when running qmicli —uim-get-card-status.  

In ModemManager debug it of course also reports:
Application ‘sim’ [0] in card [0]: illegal

So, my questions are: Where can I read up on these QMI Card Application States? What could possibly cause this?  Would it be software related is the SIM itself entering an illegal state? Could something be wrong with the SIM on a hardware level?

All the best,

More information about the libqmi-devel mailing list