[Libreoffice-qa] gdb: bt with symbols for 4.2.0 on Ubuntu

Sophie gautier.sophie at gmail.com
Thu Feb 13 18:23:04 CET 2014

Hi Bjoern,
Le 13/02/2014 17:54, Bjoern Michaelsen a écrit :
> On Thu, Feb 13, 2014 at 04:55:15PM +0100, Sophie wrote:
>> I've installed libreoffice-dbg, but the package is based on 4.1.3, and
>> if I run soffice --backtrace this version is launched, which seems correct.
>> If I run gdb /opt/libreoffice4.2/program/soffice.bin, I've no symbols
>> here :)
> So, /opt/libreoffice4.2/program/soffice.bin is the TDF build and yeah the
> libreoffice-dbg symbols wont work for them. The libreoffice-dbg symbols only
> work for the Ubuntu build they are created for (that would be the LibreOffice
> at: /usr/lib/libreoffice/program/soffice.bin). If you are running Ubuntu 13.10
> without any PPA, that is indeed LibreOffice 4.1.3.

yes, that's it.
> You can get a packed LibreOffice 4.2.0 (with a debug package that gives you
> symbols) from:
>  https://launchpad.net/~libreoffice/+archive/ppa
> There is a nice video explaining how to install that PPA:
>  https://www.youtube.com/watch?feature=player_embedded&v=BVSmqEz694E
> That version is then replacing the 4.1.3 version and the libreoffice-dbg
> package should work against it.

Oh great, thanks a lot!
>> So I think you're right, I may need my own build with debug
>> symbols enabled.
> Or that. ;)

I will avoid for now :)


More information about the Libreoffice-qa mailing list