[Libreoffice-qa] Bibisect Requests

Norbert Thiebaud nthiebaud at gmail.com
Sun May 10 16:37:56 PDT 2015

On Sun, May 10, 2015 at 5:52 PM,  <dk122 at torfree.net> wrote:
> Quoting "Norbert Thiebaud" <nthiebaud at gmail.com>:
>> I've also put together a 'sample of a bibisect for Windows
>> git://gerrit.libreoffice.org/bibisect-win32-5.0
>> about 400MB
> I have cloned the repo onto Windows Vista.  However, with both
> "oldest" and the latest versions, I observe:
> (*) instdir/program/soffice.exe reports "The program cannot find the
>     file specified.".

it of course works locally here.. and I cloned it on a windows 2012 r2
and it worked there...
humm... the usual message is "The _system_ cannot find the file specified"
is it that that you are seeing:
if so check for permission... and possibly:
start a console, cd to where soffice.exe is and run soffice.exe there

> (*) instdir/program/soffice.bin reports "The application failed to
>     start because sal3.dll was not found...".  However,
>     instdir/URE/bin/sal3.dll does exist.

that does not work here either (same error). I do not think that is
expected to work.

> (*) There is no file instdir/program/bootstrap.rc, which I expected to
>     edit w.r.t. UserInstallation.  Or, is this expectation good only
>     for Linux?
Absolutely no ideas... but there is a bootstrap.ini, maybe that serve
the same purpose on Windows ?
but surely one would hope that one does not have to tweak it to run,
that would make using bibisect quite cumbersome


Thanks for the feedback.
I was concerned about something like that, hence the test run...
I am not a windows user.. I have no ideas about what things should
look like, and very little idea how to debug that things, beyond what
google says.
I just worked based on the hypothesis that instdir was runnable and


More information about the Libreoffice-qa mailing list