[Libreoffice] [PATCH] Fix bug where an opening quote mark is treated as a word

Mattias Johnsson m.t.johnsson at gmail.com
Fri Nov 5 20:14:29 PDT 2010

On 6 November 2010 12:13, John LeMoyne Castle <jlc at mail2lee.com> wrote:
> Hi all,
> Ok, after getting over a short-term dislike of Word Count - with a new found
> appreciation for some of the developer comments in OOo issuezilla - I had a
> new idea for a test plan.  Perhaps turning on the Scanner clipping has
> *accidentally*  fixed the quote problem as well.  Although I intended to
> make no changes within the SwScanner  --  the two changes at issue are
> small:  Mattias fix of specifying the ScriptType for the fancy punctuation
> is one initializer in an array, and the Scanner clipping on/off is a Boolean
> true/false parameter on the SwScanner constructor.  So hoping for quick
> clarity, I backed out both changes.
> Of course the plan fell apart at step 1) - can see the packaging of core-04
> involving libswli.so and core-05 involving new i18npool.so - also did full
> rm-Rf install and make dev-install to make sure I get the new stuff.  - both
> changes removed - Still no 'leading special quote extra word' [LSQEW]
> problem with quotes from an existing file or quotes newly inserted into a
> doc.
> Get LSQEW on Oracle OOo 3.2 Linux on Lucid.
> Get LSQEW on LibO Beta2 on Win Vista.
> I can not recreate it in dev.
> In case some other change in CountWords fixed it I tried rolling the history
> back.  After a bunch of
>> git diff HEAD~<dozens> -- ./txtedt.cxx
> including a binary search to pin down the point just before our changes - a
> few weeks ago -
> I rolled CountWords back -40 with:
>> git checkout -f HEAD~40 ./txtedt.cxx
> Saw the code as it was before any of our changes.  Built soffice and ran but
> still no LSQEW.  Know I built the old version txtedt.cxx because Char excl
> spaces was always zero.  And selections across a leading special quote still
> always gave the 'correct' MSWord count.
> Looked further back ~200-500 and very few changes in CountWords (nParaAll++
> insertion; 2 changes in TxtNode member names; change in ParaDataImpl_
> WrongList type) .  Did similar look back in history for the breakiterator
> file and few changes there as well.
> *Maybe a closer look at the scanner or the iterator will turn up something
> -- but further back than the copyright change not likely to help since it
> shows as broken in Beta 2 and in current OOo for Lucid from Ubuntu.
> If you try the 'go back machine' you may need to search a further back than
> 40 because of any commits to origin/master since my test (11/5).  In this
> search it helped to step back partway before the last larger set of changes
> to be able to see the earlier changes.  Easy to see far enough because the
> new field in ParaDataImplwhatever showed at the bottom of the diff.  When
> done  'cleaned up' the local config with
>> git checkout -f origin/master ./txtedt.cxx
> Still new to git but I am sure I saw and built and ran the old txtedt.cxx
> and still no LSQEW.  Feelin' a bit lost ... I can think of some other
> options for trying to find what fixed the LSQEW but I feel like I'm chasing
> ghosts where they aren't.   Maybe I have a magic bug eating build setup. I
> hope not -- that would make troubleshooting impossible ;-)
> Puzzled but not daunted --  LeMoyne

Okay, I can confirm. I pulled the latest master, built it, and there's
no opening quote mark problem. I have no idea what's going on.

I think I'm just going to let it go for the moment, and pick another
bug to fix. Hopefully one that doesn't magically fix itself, this

More information about the LibreOffice mailing list