[Libreoffice] Compile problems

Petr Mladek pmladek at suse.cz
Tue Oct 5 12:12:13 PDT 2010

Marco ''AlpVonKri'' Flores píše v Ne 03. 10. 2010 v 09:07 -0500:
> Thanks to all for your advices, I solved the problem thanks to your
> help, I found that I was compiling for KDE 4 and KDE 3, so this is how
> the problem was solved:
> Finishing the mono installation...
> Failure adding assembly /opt/libreoffice/ure/lib/cli_basetypes.dll to
> the cache: gac directories could not be create, possibly permission
> issues.

The mono stuff is installed by libreoffice/build/bin/install-mono.
It should do nothing if you are not root. See the check:

if ! test -w "$OODESTDIR/" ; then
    echo "Warning: You do not have rights to finish the mono
    echo "         => skipping it"
    exit 0;        

Either the check is not sufficient. Or your mono installation is somehow
broken or non-standard.

Another possibility is that you have the GAC cache in a non-standard
prefix. You might redefine it with the --with-mono-gac configure option.
For example, I use --with-mono-gac=/usr/lib because I have the gac in 
/usr/lib/mono/gac/ even on 64-bit system. Other stuff is is /usr/lib64

Anyway, as Michael said, you might also --disable-mono. No functionality
is written in mono, so there is no loss in the real life.

Best Regards,

More information about the LibreOffice mailing list