[Libreoffice] SDK installation problem was: libreoffice- tag created (3.5.0-beta1)

Petr Mladek pmladek at suse.cz
Tue Dec 20 11:11:36 PST 2011

Petr Mladek píše v Čt 15. 12. 2011 v 11:09 +0100:
> Andreas Radke píše v St 14. 12. 2011 v 22:48 +0100:
> > build is done in a clean chroot each time. shouldn't be a problem. the
> > beta0 built fine here.
> > the only difference to beta0 is the changed internal libvisio src bump.
> > tried autoconf/autoreconf and make -j1 install without luck :(
> It is really strange. Tomas have problems to reproduce it as well. It
> happened him when he did a clean build. It did not happen when he tried
> to reproduce it as root.

I have finally got time to look at it. There were two problems:

1. core/bin/distro-install-sdk move many files to /usr/share to make it
LSB-compliant. It creates compat symlinks in /usr/lib; The symlinks are
absolute and invalid if you use $DESTDIR.

2. As Tomas found, "make distro-pack-install" did the installation twice
from some reasons. The second installation failed because it tried to
access files via the invalid symlinks.

I am not able to find why the installation is called twice. The gbuild
stuff is still a bit cryptic to me :-)

Though, I have updated ooinstall to cleanup $DESTDIR before installation
starts. It works fine now. I am not 100% sure that we want this
solutions. Well, it makes some sense even after we fix the installation

Unfortunately, it was too late to get this into beta2. You might find
the change at 

Best Regards,

More information about the LibreOffice mailing list