[Libreoffice] Should the Thesaurus/mythes use a precomputed index (installer file size)

Steven Butler sebutler at gmail.com
Thu Feb 3 02:29:55 PST 2011

On 3 February 2011 13:13, Steven Butler <sebutler at gmail.com> wrote:

> It seems to have failed building VCL - there is an error stating
> f268: Error: The image(s) <check ...> could not be found. (my elision
> as different PC)

For some reason git fetch from my linux machine's repository didn't
fetch any of the new objects I'd fetched on it.

I used git config to repoint at the freedesktop repositories and did
an update and it is currently still compiling so hopefully all will go

Here's the errors I had and how I worked around them to get the build happening:

16. Got this warnign but not an error:
cygwin warning:
  MS-DOS style path detected: C:/cygwin/home/Steve/libre/libo
  Preferred POSIX equivalent is: /home/Steve/libre/libo
  CYGWIN environment variable option "nodosfilewarning" turns off this warning.
  Consult the user's guide for more details about POSIX paths:

Checking for prebuilt Mozilla libraries ... found.
realpath: No such file or directory
cygpath: can't convert empty path

17. make
C:/cygwin/home/Steve/libre/libo/download: line 212: C:/cygwin/home/Steve/libre/
ibo/src/dbghinst.EXE: Permission denied
md5sum: C:/cygwin/home/Steve/libre/libo/src/tmp/dbghelp.exe: No such file or di

NOTE: We are running the Microsoft KB975337 security fix installer
to get gdiplus.dll. You will most probably get a UAC prompt now.
If you trust us, just enter your administrator password.
The security fix is run with the /extract switch to just unpack
its files.
If you don't trust us, just get gdiplus.dll yourself and put it
in external/gdiplus/gdiplus.dll.
gdiplus.dll is included in the LibreOffice installer for the benefit of
Windows 2000 users.

Access is denied.
WindowsXP-KB975337-x86-ENU.exe did not unpack the expected asms/10/msft/windows
cp: cannot create regular file `./external/vcredist/vcredist_x86.exe': No such
ile or directory
cp: cannot create regular file `./external/vcredist/vcredist_x64.exe': No such
ile or directory
'post_download' script not found, run ./autogen.sh.
make: *** [dmake/dmake] Error 1
These would not run until chmod 755 was done on them (Maybe 700 would
also have worked?)
18 chmod 755 src/*.EXE src/*.exe
19. gdiplus was unpacked into the wrong directory - I picked default -
copied manually and remake

More information about the LibreOffice mailing list