[Libreoffice] [Patch] it needs to be check by libreoffice guru

Petr Mladek pmladek at suse.cz
Tue Jun 7 11:44:37 PDT 2011

Dimitri Duc píše v Ne 05. 06. 2011 v 18:06 +0200:
> Here the log files.
> The command from ./desktop/unxmacxi.pro/misc/oosplash.oosplash_1.cmd gives me this error. It's missing "-L/usr/X11/lib -lX11"
> To compile libreOffice, Macport is disable.
> MacBook-Pro-de-Dimitri-Duc:~ dimitri$cat .profile
> # MacPorts Installer addition on 2010-08-04_at_09:03:14: adding an appropriate PATH variable for use with MacPorts.
> #export PATH=/opt/local/bin:/opt/local/sbin:$PATH
> # Finished adapting your PATH environment variable for use with MacPorts.
> Is it normal Libreoffice compile oosplash from ./desktop/unx/source in a Mac environment ?
> I recompiled with "-L/usr/X11/lib -lX11" in osplash.oosplash_1.cmd. it worked on my mac (ver 10.6.7). Then I copied LibreOffice.app into another Mac (ver 10.5.8) without Macport and any extra lib file installed. It worked fine.

Christian. Thorsten, what do you think about it?

Do we want to go even further and set X11LINK_DYNAMIC in

Best Regards,

PS: Dimitri, it is better to keep the interested people in CC.
Otherwise, they might miss your answer on this high trafic mailing
list :-)

More information about the LibreOffice mailing list