[Libreoffice] [Patch] it needs to be check by libreoffice guru

Dimitri Duc dimitri.duc at gmail.com
Sun Jun 5 09:06:38 PDT 2011

Here the log files.

The command from ./desktop/unxmacxi.pro/misc/oosplash.oosplash_1.cmd gives me this error. It's missing "-L/usr/X11/lib -lX11"

To compile libreOffice, Macport is disable.

MacBook-Pro-de-Dimitri-Duc:~ dimitri$cat .profile
# MacPorts Installer addition on 2010-08-04_at_09:03:14: adding an appropriate PATH variable for use with MacPorts.
#export PATH=/opt/local/bin:/opt/local/sbin:$PATH
# Finished adapting your PATH environment variable for use with MacPorts.

Is it normal Libreoffice compile oosplash from ./desktop/unx/source in a Mac environment ?

I recompiled with "-L/usr/X11/lib -lX11" in osplash.oosplash_1.cmd. it worked on my mac (ver 10.6.7). Then I copied LibreOffice.app into another Mac (ver 10.5.8) without Macport and any extra lib file installed. It worked fine.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: Archive.zip
Type: application/zip
Size: 27387 bytes
Desc: not available
URL: <http://lists.freedesktop.org/archives/libreoffice/attachments/20110605/07d4c421/attachment-0001.zip>
-------------- next part --------------

Christian Lohmaier wrote:
> what is the full output? I suspect you have a "dirty" environment,
> i.e. the error is actually caused by macports or fink or darwinports
> stuff, and not by the LO build itself. (What configure options did you
> use?)
> It builds fine without X here, and X shall definitely not be required
> for running anymore, so the patch will get a "-1" from my part.
It even builds fine here with some macports in the path - so yeah,
detailed configure.log / autogen.lastrun / env / build log would be
required for further analysis.


-- Thorsten

More information about the LibreOffice mailing list