[Libreoffice] Debugging crash in 3.3.2 on Mac OS X 10.6.6

Peter Teeson peter.teeson at bell.net
Sat May 7 13:14:42 PDT 2011

<smile of satisfaction>
OK Now I have a successful build I would like to work on my original issue.
Using the downloaded 3.2.2 LO I get a reproducile crash on my regular Mac OS X 10.6.6 system.
But no problem on a brand new Mac OS X 10.6.7 installation (separate partition and nothing else except LO 3.2.2).
So I hypothesize my regular system is foobar in some way that kills LO 3.2.2.

Here is how I make it crash:
(0) Launch LO
(1) New Spreadsheet
(2) Format/Cells...

The log indicates:
Exception Codes: KERN_INVALID_ADDRESS at 0x000000001963fc68
Crashed Thread:  0  Dispatch queue: com.apple.main-thread

Thread 0 Crashed:  Dispatch queue: com.apple.main-thread
0   ...ple.ApplicationServices.ATS	0x93c7ccc6 OTL::GCommon::GetMaxLookupCount() const + 20
1   ...ple.ApplicationServices.ATS	0x93c7bc82 ProcessRunCommon(OTL::GCommon&, TGlyphArray&, long, long, unsigned long, bool) + 254
2   ...ple.ApplicationServices.ATS	0x93c1e1ca ProcessGSUBRun + 222
3   ...ple.ApplicationServices.ATS	0x93c17cc1 ApplyMorphForRun + 425
4   ...ple.ApplicationServices.ATS	0x93c7978b ApplyMorph + 137
5   ...ple.ApplicationServices.ATS	0x93c16fe1 _eLLCLayoutText + 274
6   ...ple.ApplicationServices.ATS	0x93c16eb8 LLCLayoutText + 83
7   com.apple.QD                  	0x945e3c19 ATSULayoutGlyphs(TATSUGlyphRecordArray*, ATSLineLayoutLineParams*, long, ATSUTab const*, unsigned long, __CFString const*, unsigned short const*, unsigned long, unsigned long) + 197

Even if there is something foobar on my regular system I'm curious why it would crash LO.

So here is my game plan (comments welcomed):
(a) Build a version and package it. Then launch it.
    Why do this? To see if original version is somehow corrupted.
    [I did in fact delete and re-install it from LibO_3.3.2_MacOS_x86_install_en-US.dmg but it stil crashes]
    If the just built version works OK then we have a deeper puzzle because I used the official dmg to install on my clean system]
    So I did an
    ./autogen.sh --with-epm --with-package-format="osx dmg" CC="ccache /usr/bin/gcc-4.0" CXX="ccache /usr/bin/g++-4.0" --with-num-cpus=8 --with-max-jobs=8 --disable-mozilla --disable-systray

    But I get this at the end....
Building module instsetoo_native
Entering /Users/pteeson/git/libo/instsetoo_native/inc_openoffice/windows/msi_languages

Entering /Users/pteeson/git/libo/instsetoo_native/inc_openoffice/unix

Entering /Users/pteeson/git/libo/instsetoo_native/util

find: /Users/pteeson/git/libo/translations/source/: No such file or directory
dmake:  makefile.mk:  line 231:  Warning: -- Prior to dmake 4.5 only one
%-target per target-definition worked reliably. Check your makefiles.

dmake:  makefile.mk:  line 286:  Warning: -- Prior to dmake 4.5 only one
%-target per target-definition worked reliably. Check your makefiles.

No EPM: do no packaging at this stage

Multiprocessing build is finished
Maximal number of processes run: 8

I guess this means I have to install EPM? Correct?

(b) If the just built version crashes then make a debug version and see if it can help trace the problem
     But if the debug version does not crash then I've no idea what else to do.




-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.freedesktop.org/archives/libreoffice/attachments/20110507/ec070ed5/attachment.html>

More information about the LibreOffice mailing list